home *** CD-ROM | disk | FTP | other *** search
/ Nebula 2 / Nebula Two.iso / SourceCode / Flip / makefile.nix < prev    next >
Makefile  |  1995-06-12  |  2KB  |  65 lines

  1. # Makefile for flip for **IX.  ::[[ @(#) makefile.nix 1.4 89/07/04 12:00:02 ]]::
  2.  
  3. # The contents of this makefile are hereby released to the public domain.
  4. #                               -- Rahul Dhesi 1989/06/19
  5.  
  6. # Before use make sure this file is called "makefile".  (Rename it if
  7. # necessary.)  Then invoke as follows:
  8.  
  9. #   "make sys_v"        makes executable flip for System V Release 2
  10. #   "make bsd"          makes executable flip for 4.3BSD
  11. #   "make install"      moves flip into BINDIR, copies flip.1 into MANDIR
  12. #   "make clean"        deletes object and executable files
  13.  
  14. # Where to install executable and manual files on "make install".  The trailing
  15. # "/." forces an error message if the destination directory doesn't exist.
  16. BINDIR = /usr/local/bin/.
  17. MANDIR = /usr/man/man1/.
  18.  
  19. # CC is compiler, LD is loader (may be same as compiler), CFLAGS are flags
  20. # for compiler, LDFLAGS are flags for loader, CFMORE are additional
  21. # (relatively unchanging) flags for compiler
  22.  
  23. CC = cc
  24. CFLAGS =
  25. CFMORE = -c -DNDEBUG -O
  26. LD = cc
  27. LDFLAGS = -o flip
  28.  
  29. # If your system does not supply getopt as a library function,
  30. # add getopt.o to the RHS list on the next line and uncomment the
  31. # two nonblank lines after that.
  32. OBJS = flip.o
  33.  
  34. #getopt.o: getopt.c flip.h
  35. #    $(CC) $(CFLAGS) $(CFMORE) $*.c
  36.  
  37. nothing:
  38.     @echo \
  39.     'Please type "make sys_v", "make bsd", "make uport", or "make ultrix"'
  40.  
  41. sys_v:
  42.     make "CFLAGS=-DSYS_V" flip
  43.  
  44. uport:
  45.     make "CFLAGS=-DSYS_V -Ml" "LDFLAGS=-Ml -o flip" flip
  46.  
  47. bsd:
  48.     make "CFLAGS=-DBSD" flip
  49.  
  50. ultrix:
  51.     make "CFLAGS=-DBSD -DULTRIX_BUG" flip
  52.  
  53. flip: $(OBJS)
  54.     $(LD) $(LDFLAGS) $(OBJS)
  55.  
  56. flip.o: flip.c flip.h
  57.     $(CC) $(CFLAGS) $(CFMORE) $*.c
  58.  
  59. clean:
  60.     rm -f *.o core flip
  61.  
  62. install:
  63.     mv flip $(BINDIR)
  64.     cp flip.1 $(MANDIR)
  65.